Hyper Plan v2.3 Quick Start Guide

Get started in no time!

Hyper Plan is a simple, but flexible, visual planning, tracking and scheduling tool. This quick start guide should only take a few minutes to work through. If you have ever planned something by sticking colored notes to a wall, then you already understand most of what you need to know.

Concepts

The main concepts in Hyper Plan are:

Cards: Typically you will want one card for each task or element in your plan. For example, you might want a card for “get a quote for website design”.

Properties: Every card in a plan has the same set properties. For example, “name”, “duration”, “cost”, “status”, “person assigned to” or “due date”. You can have as many or as few properties as you want. Choose whatever properties are important to you in your planning.

Values: Each card has a value for each property. Values can be dates (e.g. "1/2/2015"), numbers (e.g. "10"), text (e.g. "urgent") or empty.

Layout and color: You can quickly lay out and color cards in lots of different ways, according to their properties.

Filters: You can control which cards are visible using simple or advanced filtering.

Totals: Easily display totals, sliced and diced in various ways. A bit like pivot tables in Excel®, but much easier!

Charts: Easily create bar charts, e.g. the amount of effort assigned per person by category.

Open a sample

Let’s open a sample plan and have a play.

Select File>Open and choose the project plan sample that was installed into your Documents/HyperPlan folder.

Hyper Plan with sample

Here the:

  • columns represent task "Status" ("to do/doing/blocked/done").
  • rows represent the "Person" tasks have been assigned to ("Andy/Claire/John" ).
  • card colors represent the "Priority" of the tasks (high/medium/low).

Currently the "Name" property is showing in the card.

If you hover over a card, a tooltip will appear with all the properties for that card.

card tooltip

The plan will be zoomed to show all the cards while Zoom fit is pressed in. You can also zoom in/out on the cards using the zoom buttons, the zoom slider or the mouse wheel (if you have set the mouse wheel to zoom in the Preferences window).

Zoom in/out

You can also magnify the area under the cursor. Click the button and hover the cursor over a card.

Magnify cursor

Click the magnify button again (or press the Escape key) to disable magnify.

Editing

Double click on one of the cards in the "doing" column to edit it and change the "Status" drop-down list to "done".

Edit status property

Notice how the card moves to the "done" column.

Select a card and drag it to a different row and/or column. Double click on the card and notice how the "Status" and/or "Person" "properties of that card have been updated.

Click away from a card and drag out a rectangle to select multiple cards. Select Edit>Edit Card(s)... from the main menu and type in their "Status" property as "unassigned". Notice how a new column is created for the "unassigned" cards.

Edit status property

You can also select multiple cards using Ctrl+click (Windows)/Cmd+click (Mac OS X).

If you are dragging multiple cards note that holding down the Shift key and dragging horizontally preserves the column values of the cards. Similarly holding down the Shift key and dragging vertically preserves the row values of the cards.

Layout and color

We can slice information in multiple ways. In the Layout/Color section of the Left pane:

  • Change the Arrange rows (Y) by drop-down list from "Person" to "Priority".
  • Change the Set card color by drop-down list from "Priority" to "Duration".
Edit status property

The cards are now colored according to their duration. We can change the colors used by clicking on the small button next to the Set card color by drop-down list. Currently minimum duration tasks are shown in red and maximum duration in green. Click on the red and green color buttons in the Colors tab to use different colors, e.g. orange and blue.

Edit property colors

Click OK when you are done.

Ordering

Now let’s change the priorities so that "high" is shown as the top row and "low" as the bottom row. Click the small button next to the Arrange rows (Y) by drop-down list. Change the order in the Ordering tab by selecting "high" and "low" and re-ordering them using the up and down arrows".

Edit property ordering

Click OK when you are done. You can also change column or row ordering by clicking in column/row headers and dragging.

Pre-defined values

The "Priority" rows are defined by the "Priority" values of all the cards. This means that deleting all the cards with a particular "Priority" value will remove that row. You can avoid this by making "low", "medium" and "high" pre-defined values. Again click the small button next to the Arrange rows (Y) by drop-down list. Then click on the Pre-defined Values tab and click the Add current values button.

Edit pre-defined

There will now be "low", "medium" and "high" rows, even if you delete all the cards. Click OK when you are done.

You can also add pre-defined values by right-clicking on a column header and selecting Add Column Left or Add Column Right from the pop-up menu. Similarly for rows.

Add columns

Images

Images can be a useful visual cue. To add an image to a card, just drag and drop an image file from Windows Explorer (Windows) or the Finder (Mac OS X) directly on to the card. You can also create a new card by dragging and dropping an image away from any cards. If you have already added an image to a plan, you can select it from the Image drop-down list in the Edit Card window. You can control the visibility, size and position of images in the Show Properties section.

Add columns

Hyper Plan can accept images of type PNG, JPG and BMP. Images larger than 128x128 will be scaled to 128x128 inside Hyper Plan (the original file is unchanged).

Totals

Now let’s total the duration by "Status" and "Priority". Change the Show total for drop-down list to "Duration".

Edit total

Gray rectangles are now shown with the total duration for each row and column. Check in cells to also show totals for each cell. Zoom in or use the magnify cursor if you can't read them easily.

Change the Arrange columns (X) by drop-down list from "Status" to "Person". Notice how the totals update. The totals will also update if you drag cards between rows and/or columns.

Filtering

Let’s hide all the "done" tasks. In the Filter section set the drop-down list to Hide and type in "done". All the cards that have status "done" will be hidden (also any cards with "done" in another property or in their Notes field).

Filter unwanted cards

Use the Ctrl+F (Windows)/Cmd+F (Mac OS X) shortcut to go straight to the Filter section.

Searching

You can use the Search section to select cards with text that matches your search. You can optionally zoom in on selected cards. Only text currently displayed in the card counts for search. Press the refresh button to re-run the search. The search is not case sensitive.

Search cards

The Charts Tab

You can easily display bar charts in the Charts tab.

  • Set the Show drop-down to the numerical property you want to use for the height of the bars (you can also show the number of cards).
  • Set the By drop-down to display a bar for each value of that text property.
  • Set the Per drop-down to display a chart for each value of that text property.
Charts pane

You can change the appearance of the chart in the Appearance section of the Charts pane.

The Table Tab

You can also edit your data in the Table tab.

Table pane

Currently the rows are colored by the status of each card. You can change this in the Appearance section.

Note that changes in the Table tab update the Cards and Charts tabs. Try it.

The Properties tab

You can see, edit and re-order all the properties in the Properties pane.

Properties pane

Views

Each setting of Layout/Color, Show Properties and Filter is a 'view'. To save the current view, go to the Cards tab, click the + button under Stored Views and give the view a name.

Add a stored view

You can retrieve this view at any time by selecting it from the Stored View drop-down list. You can change to the next or previous view using the keyboard shortcuts Ctrl+[ (Windows) / Cmd+[ (Mac OS X) and Ctrl+] (Windows) / Cmd+] (Mac OS X). Or you can select the Nth view using the keyboard shortcut Ctrl+<N> (Windows) / Cmd+<N> (Mac OS X) where <N> is 1 to 9 (e.g. Ctrl+1 selects the first view on Windows).

Adding new cards and properties

To add a new card either:

  • select Edit>Add card; or
  • click the Add card toolbar icon; or
  • use the Ctrl+I (Windows)/Cmd+I (Mac OS X) shortcut; or
  • Alt+Left-click (Windows)/Option+Left-click (Mac OS X) on a cell in the Cards pane.

To add a new property select Edit>Add property (or use the Add property toolbar icon or Ctrl+Shift+I (Windows)/Cmd+Shift+I (Mac OS X) shortcut). You can set the Type to Automatic, Text, Numeric or Date. If you choose Automatic Hyper Plan will infer the type as Text, Numeric or Date from the data values. All existing cards will have the new property value set to the Default value.

Undo/Redo

You can undo and redo edits using Edit>Undo and Edit>Redo.

Printing and exporting

You can print the Cards or Charts pane straight from Hyper Plan by selecting File>Print... . Use File>Page Setup... to change the page size or orientation.

You can export to various formats by selecting File>Export. CSV files can be opened in Excel. SVG format can be edited using vector graphics packages such as Inkscape (free) and Abobe Illustrator (commercial).

Starting a new plan

Select File>New to create a new empty plan. Discard any changes to the sample plan. Try adding your own cards and properties.

Opening a CSV file

Note that you can read in CSV (comma separated value) files, so you don’t have to re-type everything for Hyper Plan. Just select File>Open then set the file type to CSV files.

Open a CSV file

Columns are imported as properties and rows as cards. The first row is used for the property names. Columns headed Images, Notes and Links are imported as images, notes and hyperlinks respectively. All other columns are imported as standard properties. For example:

Import CSV example

You will be given the option to import the CSV data into a new plan or the current plan.

Using Hyper Plan in a multiple-user/multiple-computer environment

To help Hyper Plan play nicely in a multiple-user/multiple-computer environment:

  • It locks the plan file you have opened, so that no-one else on your network can write to it, while you have it open (Windows only).
  • You can open a plan file as read-only to avoid locking it (Windows only).
  • It detects changes made to your plan file by other people/programs and gives you the option to load these changes.
  • All the data for a plan is stored in a single plan file. The format is the same on Windows and Mac OS X. This means it can be easily moved between computers and works well with file synchronization systems such as DropBox.

We're done!

Have a play and see what else you can find out. Happy planning! ;o)

Once you are a bit more familiar with Hyper Plan, then please check out the expert tips page.

Questions/Suggestions?

Check the FAQ or email us at:

hyperplan@oryxdigital.com

Excel is a registered trademark of Microsoft Corporation