Hyper Plan v2.6 Expert Tips

These tips are intended to help expert users get more out of Hyper Plan. A quick start guide to Hyper Plan is available here.

Images

Images can be a useful visual cue. To add an image to a card, just drag and drop an image file from Windows Explorer (Windows) or the Finder (Mac) directly on to the card. You can also create a new card with an image by dragging and dropping an image away from any cards. If you have already added an image to a plan, you can select it from the Image drop-down list in the Edit Card window. You can control the visibility, size and position of images in the Show Properties section.

Add columns

Hyper Plan can accept images of type PNG, JPG and BMP. Images larger than 128x128 will be scaled to 128x128 inside Hyper Plan (the original file is unchanged).

Magnification

You can magnify the area under the cursor. Click the button and hover the cursor over a card.

Magnify cursor

Click the magnify button again (or press the Escape key) to disable magnify.

Icon overlay

Select View>Icon Overlay to create, edit and delete cards in the Cards pane using icons that appear as you hover over cards and cells.

Icon overlay

Searching

You can use the Search section of the Cards pane to select cards with text that matches your search. You can optionally zoom in on selected cards. Only text currently displayed in the card counts for search. Press the refresh button to re-run the search. The search is not case-sensitive.

Search cards

Stored views

Each setting of Layout/Color, Show Properties and Filter in the Cards pane is a 'view'. To save the current view, go to the Cards tab, click the + button under Stored Views and give the view a name.

Add a stored view

You can retrieve this view at any time by selecting it from the Stored View drop-down list or (from v2.5.2) the main View menu. You can change to the next or previous view using the keyboard shortcuts Ctrl+[ (Windows) / Cmd+[ (Mac) and Ctrl+] (Windows) / Cmd+] (Mac). Or you can select the Nth view using the keyboard shortcut Ctrl+<N> (Windows) / Cmd+<N> (Mac) where <N> is 1 to 9 (e.g. Ctrl+1 selects the first view on Windows).

Printing and exporting

You can print straight from Hyper Plan by selecting File>Print... . Use File>Page Setup... to change the page size or orientation.

You can export to various formats by selecting File>Export. CSV files can be opened in Excel. SVG format can be edited using vector graphics packages such as Inkscape (free) and Abobe Illustrator (commercial).

Opening CSV files

You can read in CSV (comma separated value) files, so you don’t have to re-type everything for Hyper Plan. Just select File>Open then set the file type to CSV files.

Open a CSV file

Columns are imported as properties and rows as cards. The first non-empty row is used for the property names. Columns headed Images, Notes and Links (not case-sensitive) are imported as images, notes and hyperlinks respectively. All other columns are imported as standard properties. For example:

Import CSV example

You will be given the option to import the CSV data into a new plan or the current plan.

Dates

In the Preferences window you can set the Date format field to choose whether to use DD-MM-YYYY, MM-DD-YYYY or YYYY-MM-DD format for dates.

You can enter dates in a wide range of forms, which will then be converted into a date value in your chosen format. The names accepted for days of the week and month of the year will depend on your system locale. For example, if your chosen format is DD-MM-YYYY and your operating system locale is English, all the following dates will be understood by Hyper Plan:

  • 01 January
  • 1/Jan/2018
  • 01-01-18
  • today
  • tomorrow
  • Monday
  • mon
  • +7

In the example below only cards with a due date of today are shown:

filter by relative date

Hover over a date field for more information.

Note that these intelligent date values only work if you have explicitly set the property type to 'Date'. Date properties fields also show a date picker button.

Quick add

You can use the Quick add field in the Add card window to quickly set properties. Check the Show 'Quick add' field check box at the bottom of the Add card window to make the Quick add field appear.

'Quick add' field

Then type the property names (not case-sensitive) and values separated by commas or semi-colons into the Quick add field. For example:

Add a card

Values that are not supplied are set to the default value for the property.

You can also use abbreviations. For example:

Add a card

You can even omit the property names and let Hyper Plan try to intelligently work them out from the values. For example:

Add a card

Press the Return key when you are done or Escape to discard the changes.

Multiple-user/multiple-computer environments

To help Hyper Plan play nicely in a multiple-user/multiple-computer environment:

  • It locks your plan while you are modifying it, so that no other program on your network can write to it (Windows only). This ensure your plan file is not corrupted by two programs writing to it at the same time.
  • It detects changes made to your plan file by other people/programs and automatically loads these changes.
  • If you try to write to a file that someone else has modified, your changes will be saved in a new 'conflict' file, so they aren't lost.
  • All the data for a plan is stored in a single plan file. The format is the same on Windows and Mac. This means it can be easily moved between computers and works well with file synchronization systems such as DropBox.

A version of Hyper Plan that supports multiple users simultaneously editing the same plan is a possibility in future, if there is enough demand. Email us if you are interested.

Running from a memory stick

To find out how to run Hyper Plan from a a USB memory stick, or other portable device, please see 'Can I run Hyper Plan from a memory stick or other portable device?' in the FAQ.

Keyboard shortcuts

The following keyboard shortcuts are available:

Windows Mac Action
Ctrl+A Cmd+A Select All (Cards pane/ Table pane)
Ctrl+B Cmd+B Open/close Layout Color Cards(Cards pane)
Ctrl+D Cmd+D Duplicate card(s) (Cards pane)
Ctrl+E Cmd+E Edit card(s) (Cards pane)
Ctrl+F Cmd+F Open/close Filter Cards (Cards pane/Charts pane/Table pane)
Ctrl+Shift+F Full screen
Ctrl+G Cmd+G Open/Close Display Charts
Ctrl+H Replace
Ctrl+I Cmd+I Add card
Ctrl+Shift+I Cmd+Shift+I Add property
Ctrl+J Cmd+J Open/close Appearance (Cards pane/Charts pane)
Ctrl+K Cmd+K Open/close Show Card Properties (Cards pane)
Ctrl+L Cmd+L Toggle Left pane (Cards pane/Charts pane)
Ctrl+M Cmd+M Minimize Main window
Alt+M Option+M Toggle magnify cursor (Cards pane)
Ctrl+N Cmd+N New plan
Ctrl+Shift+N Cmd+Shift+N New Main window
Ctrl+O Cmd+O Open plan
Ctrl+P Cmd+P Print
Ctrl+R Cmd+R Open/close Stored Views (Cards pane)
Ctrl+S Cmd+S Open/close Search Cards (Cards pane)
Ctrl+T Cmd+T Show/hide tool tips (Cards pane)
Ctrl+Shift+T Cmd+Shift+T Show/hide toolbar
Ctrl+U Cmd+U Duplicate plan
Ctrl+Y Cmd+Y Redo
Ctrl+Z Cmd+Z Undo
Ctrl+. Cmd+. Show/hide icon overlay (Cards pane)
Ctrl+, Cmd+, Preferences
Ctrl+= Cmd+= Zoom fit (Cards pane)
Ctrl++ Cmd++ Zoom in (Cards pane)
Ctrl+- Cmd+- Zoom out (Cards pane)
Ctrl+/ Cmd+/ Zoom to selected (Cards pane)
Ctrl+\ Cmd+\ Swap x/y (Cards pane)
Ctrl+[ Cmd+[ Previous stored view (Cards pane)
Ctrl+] Cmd+] Next stored view (Cards pane)
Ctrl+1 ... Ctrl+9 Cmd+1 .. Cmd+9 Choose numbered stored view (Cards pane)
Left arrowLeft arrowNext chart (when zoomed in) (Charts pane)
Right arrowRight arrowPrevious chart (when zoomed in) (Charts pane)
Ctrl+Left arrow Cmd+Left arrow Move focus to previous card in cell/previous column (Cards pane)
Ctrl+Right arrow Cmd+Right arrow Move focus to next card in cell/next column (Cards pane)
Ctrl+Up arrow Cmd+Up arrow Move focus to previous card in cell/previous row (Cards pane)
Ctrl+Down arrow Cmd+Down arrow Move focus to next card in cell/next row (Cards pane)
Ctrl+Tab Change front tab
Del, Backspace Del, Backspace Delete
Esc Esc Exit full screen mode
F1 F1 Help

Drag and drop

The following drag and drop operations are available:

Item From To Result Notes
plan (.tp) file Operating System Cards, Charts or Table panes plan is opened
.csv file Operating System Cards, Charts or Table panes .csv file is imported
image file Operating System card in Cards pane image added to card
image file Operating System Cards, Charts or Table panes new card with image added
image file Operating System Images window image added to plan
other file Operating System card in Cards pane hyperlink to file added to card
other file Operating System Cards, Charts or Table panes new card with hyperlink to file added
image Browser card in Cards pane image added to card doesn't work for all browsers
image Browser Cards, Charts or Table panes new card with image added doesn't work for all browsers
hyperlink Browser card in Cards pane hyperlink added to card
hyperlink Browser Cards, Charts or Table panes new card with hyperlink added
Cards pane column (row) header column (row) position another column (row) position change column (row) order
cards(s) Cards pane cell Cards pane cell X and Y properties of cards are updated Hold down the Shift key while dragging a column (row) of cards to a different column (row) to preserve card rows (columns)

Questions/Suggestions?

Check the FAQ or email us at:

hyperplan@oryxdigital.com